In CSS Forms we have a shape for the elements of a meter:
<meter>
├─ ::slider-track
│ └─ ::slider-fill
However, for this to be useful for styling we need some way to style based on how optimal the value of the meter element is.
WebKit (and blink) uses different pseudo elements instead of a single :slider-fill
equivalent and their naming is ::-webkit-meter-even-less-good-value
, ::-webkit-meter-suboptimum-value
and ::-webkit-meter-optimum-value
.
Firefox has a single ::-moz-meter-bar
pseudo element and instead applies pseudo classes to <meter>
these are :-moz-meter-sub-sub-optimum
, :-moz-meter-sub-optimum
and :-moz-meter-optimum
.
Using pseudo classes seems the better approach between the two. I suspect we can drop the meter prefix and just go with something like :sub-sub-optimum
, :sub-optimum
, :optimum
? But naming would need bikeshedding as neither Firefox's nor WebKit's seem great.
RetroSearch is an open source project built by @garambo | Open a GitHub Issue
Search and Browse the WWW like it's 1997 | Search results from DuckDuckGo
HTML:
3.2
| Encoding:
UTF-8
| Version:
0.7.3